by SuiteCRM

Official SuiteCRM Outlook Plugin v4 has arrived - A complete plugin rebuild developed and maintained by SuiteCRM developers entirely from scratch, the addon retains previous functionality while massively improves performance, reliability and stability!

Cancel at any time!
Free Trial

#3231 - The current user is not licensed. Please contact your administrator.

Closed Bug? created by Customer_Support Verified Purchase 2 months ago

Hi There

I have following all the installation instructions, however i get an error when i try to authenticate the plug-in.

I have uninstalled a couple of time and tested the login credentials but it will not authenticate.

Can you help please

  1. Customer_Support member avatar

    Customer_Support Verified Purchase

    2 months ago

    I forgot to mention that i have tried the instruction in https://docs.suitecrm.com/developer/api/developer-setup-guide/json-api/#_generate_private_and_public_key_for_oauth2

    But it did not make a difference

  2. suitecrm member avatar

    SuiteCRM Provider Affiliate

    2 months ago

    Hi there,

    Have you added your user to the subpanel found in the Outlook config menu?
    (See here - https://youcrm.com/index.php?module=Administration&action=OutlookAddinConfig)

    If not try adding them with the select button and seeing if authentication now works!

    Thanks,
    Mac

  3. Customer_Support member avatar

    Customer_Support Verified Purchase

    2 months ago

    Hi Mac

    Can i confirm that the

    1) Tenant ID = the Object ID on Azure?
    2) where can i find the Client ID?

    Thanks

  4. suitecrm member avatar

    SuiteCRM Provider Affiliate

    2 months ago

    1. Yes as far as im aware that should be correct.
    2. You will have to create a password grant in the API Tokens admin menu on the CRM and use the Client ID and Secret from there
  5. Customer_Support member avatar

    Customer_Support Verified Purchase

    2 months ago

    Thanks

    I'm going to start from scratch.

    I'll let you know how i get on

  6. Customer_Support member avatar

    Customer_Support Verified Purchase

    2 months ago

    Hi Again

    I have removed the plug-in and reinstalled but i still can not authenticate.

    I keep getting the same error

    enter image description here

    • Customer_Support member avatar

      Customer_Support Verified Purchase

      2 months ago

      Could you let me know which screenshots will help you help me :-)

  7. Customer_Support member avatar

    Customer_Support Verified Purchase

    2 months ago

    We are using the CRM on site and it can not be seen by the internet, would that cause the authentication to fail?

    • suitecrm member avatar

      SuiteCRM Provider Affiliate

      2 months ago

      Hi!

      Yes, that's most likely the issue. if you whitelist 104.130.124.191 on your firewall you should be able to reach the licence server and therefore be able to authenticate.

      Let me know how you get on!

      Thanks,
      Mac

    • Customer_Support member avatar

      Customer_Support Verified Purchase

      2 months ago

      Hi Mac

      Thank for you reply

      I can connect via telnet on ports 80 and 443 to 104.130.124.191. As well as being able to load the webpage. Also, that we have no outbound

      image.png

    • Customer_Support member avatar

      Customer_Support Verified Purchase

      2 months ago

      We can see Active OAuth2 Tokens being created under Outlook Password Client, every time i attempt to login

    • suitecrm member avatar

      SuiteCRM Provider Affiliate

      2 months ago

      Has the licence authorised suesssfully?

    • Customer_Support member avatar

      Customer_Support Verified Purchase

      2 months ago

      Yes, it is validated successfully in the server before i download the manifest file

  8. suitecrm member avatar

    SuiteCRM Provider Affiliate

    2 months ago

    Ok, and what does it say on the Outlook side?

  9. Customer_Support member avatar

    Customer_Support Verified Purchase

    2 months ago

  10. Customer_Support member avatar

    Customer_Support Verified Purchase

    2 months ago

    image (1).png

  11. suitecrm member avatar

    SuiteCRM Provider Affiliate

    2 months ago

    Does the user you are using exist in the Outlook Licence subpanel in the Outlook Config on SuiteCRM?

  12. Customer_Support member avatar

    Customer_Support Verified Purchase

    2 months ago

    JACKPOT!!!

    That was what was missing, Authentication Successful

    Thank you so much for you help.

  13. Customer_Support member avatar

    Customer_Support Verified Purchase

    2 months ago

    PS: I don't think that was in the instructions

    • suitecrm member avatar

      SuiteCRM Provider Affiliate

      2 months ago

      Glad to hear all is good, should you have any further issues please let me know, however for now I'll close this case over.

      I'll take a look at adding that to the guide (I'm sure it used to be part of it) as you appear to be right!

      Thanks,
      Mac

This case is public. Please leave out any sensitive information such as URLs, passwords, etc.
Saving Comment Saving Comment...