by eVolpe Consulting Group

Are you facing difficulties trying to coordinate efforts between marketing and sales? The SuiteCRM & Mautic Integrator by eVolpe is the best solution that will help you solve this issue. TRY IT NOW FOR FREE!

Free 30 day trial
Try it Now

#5005 - Mautic can't connect to SuiteCRM: "There was an unknown error encountered when trying to obtain the access token"

Closed Installation created by Andras Timar (Collabora) 11 months ago

When clicking "Authorize App" for the plugin in Mautic I get a popup with the error message saying "Authorization failed with the error message, 'There was an unknown error encountered when trying to obtain the access token.'". When doing this the apache logs for SuiteCRM show:

REDACTED - - [24/Aug/2023:10:08:00 +0000] "POST /service/v4_1_mautic/rest.php HTTP/1.1" 200 6757 "-" "GuzzleHttp/7"
REDACTED - - [24/Aug/2023:10:08:00 +0000] "POST /service/v4_1_mautic/rest.php HTTP/1.1" 200 6757 "-" "GuzzleHttp/7"
REDACTED - - [24/Aug/2023:10:08:00 +0000] "POST /service/v4_1_mautic/rest.php HTTP/1.1" 200 6757 "-" "GuzzleHttp/7"
REDACTED - - [24/Aug/2023:10:08:01 +0000] "POST /service/v4_1_mautic/rest.php HTTP/1.1" 200 6757 "-" "GuzzleHttp/7"
REDACTED - - [24/Aug/2023:10:08:04 +0000] "POST /service/v4_1_mautic/rest.php HTTP/1.1" 200 6757 "-" "GuzzleHttp/7"
REDACTED - - [24/Aug/2023:10:08:04 +0000] "POST /service/v4_1_mautic/rest.php HTTP/1.1" 200 6757 "-" "GuzzleHttp/7"

I have made sure the following: - Mautic plugin is installed and configured with a user that has access, URL is set correctly - API token generated in Mautic is present in connector settings with correct Mautic instance URL

I have noticed when I click the link to generate access tokens on the "Set Connector Properties" page I a 404, the logs say:

REDACTED - - [24/Aug/2023:10:02:06 +0000] "GET /mautic_api/get_token?state=REDACTED&code=REDACTED HTTP/1.1" 404 528 "https://REDACTED.EXAMPLE.com/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/116.0.0.0 Safari/537.36"

I am running the following: SuiteCRM 7.13.3 with PHP 8.0.29 Mautic 4.4.9 with PHP 8.0.29

  1. eVolpe member avatar

    eVolpe Consulting Group Provider

    11 months ago

    Unfortunately, our plugin does not currently support SuiteCRM version 7.13.x and PHP 8.0.

    You can find the detailed technical requirements here: https://store.suitecrm.com/docs/mautic-suitecrm-integrator

    I’m happy to answer any questions you may have.

    Best, eVolpe Support Team

This case is public. Please leave out any sensitive information such as URLs, passwords, etc.
Saving Comment Saving Comment...
  • "Install and first test worked like a charm (well documented). Except for one little thing: In my environment there was an issue with database table cr..." - Endymion

    Read More Reviews